Photos uploaded are totaly blue and others things

support forum

Photos uploaded are totaly blue and others things

Postby Henke » Thu Jul 13, 2006 3:32 am

Hi I have a new install of Leonardo on a trustix 3.0 with php 5.1.4 and I have 3 problems

1st -> The Photos uploaded are totaly blue ( i think is a quality setup problem) if is where to correct ?
2nd -> The OLC pontuation are not working ( I can't figure out where to correct this)
3rd -> To install i have modified the CL_user_prefs.php
on line 30
from $this=unserialize($cval);
to $this_var=unserialize($cval);
since on PHP5 the use of $this is prohibited

Please Help

Henke

There is a new xc leage on Brazil
http://xc.ciclone.com.br
Henke
 
Posts: 3
Joined: Thu Jul 13, 2006 3:22 am
Location: São Paulo Brasil

Re: Photos uploaded are totaly blue and others things

Postby manolis » Tue Jul 18, 2006 2:09 pm

Henke wrote:Hi I have a new install of Leonardo on a trustix 3.0 with php 5.1.4 and I have 3 problems
1st -> The Photos uploaded are totaly blue ( i think is a quality setup problem) if is where to correct ?

It seems that the GD version on your serrver is not 2.0 but 1.0
please run phpinfo() on a php script on youyr server to see whatversion of GD you have. You must have 2.0 for the images to be displayed correctly.

2nd -> The OLC pontuation are not working ( I can't figure out where to correct this)


the problem is this:
Warning: file() [function.file]: URL file-access is disabled in the server configuration in /home/httpd/html/xc/modules/leonardo/server/scoreOLC.php on line 23

have a word with your service-provider to see if they can enable "URL file-access"

3rd -> To install i have modified the CL_user_prefs.php
on line 30
from $this=unserialize($cval);
to $this_var=unserialize($cval);
since on PHP5 the use of $this is prohibited

Please read the comments below on the file...
you should comment out the 2 functions
( getFromCookie and setToCookie ) and uncomment their
php5 versions just below.
manolis
Site Admin
 
Posts: 152
Joined: Fri Jun 24, 2005 2:04 pm

Postby Henke » Tue Aug 22, 2006 4:10 pm

Hi..
The gd version are 2.033..
I Have instaled the leonardo and phpbb on a windows box with apache 2.0 and php 5.14 it works perfectly and in a trustix i have a photoalbum that works perfecty to..

i went to http://www.aditus.nu/jpgraph/jpdownload.php and there is a advisor to use jpgrap 2.x series to php5 but in a windows with php5 the jpgraph bundled with leonardo works fine..

I Will try to use Fedora 5, and others distributions, it must be a Linux Distribution or a Freebsd Distribution at the server.. I can't use Windows on the server because others services running..

And now in the maps the tracklog is shown in a grey line....

I can't figure out where is the error... please help
Henke
 
Posts: 3
Joined: Thu Jul 13, 2006 3:22 am
Location: São Paulo Brasil

Postby manolis » Mon Aug 28, 2006 6:00 pm

It seems you have resolved the problems

What have you done ?
manolis
Site Admin
 
Posts: 152
Joined: Fri Jun 24, 2005 2:04 pm

Postby Yann » Fri Sep 15, 2006 1:58 pm

I had the same problem with photos totally blue. It was because it uses the old function gd 1.x imagecreate().

I resolve it by replacing

Code: Select all
if (function_exists("gd_info")) {
    $gdinfo=gd_info();
    if ( strpos($gdinfo["GD Version"],"2.") )
        $gd2=true;
    else
        $gd2=false;
    }
else
   $gd2=false;


by (because strpos() may return Boolean FALSE, but may also return a non-Boolean value which evaluates to FALSE, such as 0 or "")

Code: Select all
if (function_exists("gd_info")) {
    $gdinfo=gd_info();
    if ( strpos($gdinfo["GD Version"],"2.") === false ) {
        $gd2=false;
    }
    else {
        $gd2=true;
    }
}
else {
    $gd2=false;
}

in CL_map.php and also in EXT_showWaypointGlobe.php and FN_functions.php

But i have still a problem with displaying maps.

Yann.
Yann
 
Posts: 5
Joined: Thu Sep 14, 2006 5:45 pm

Postby Henke » Fri Sep 15, 2006 11:52 pm

manolis wrote:It seems you have resolved the problems

What have you done ?


I have installed Fedora5 changing the jpgraph library to the new one
changing some others files to complain to new jpgraph ( extensions name)
and voila all things are working ok.
We have now 73 users with more than 200 flights on the database some flights with more than 200km in a few weeks of the site

For now i have modified the leonardo to work alone without phpbb or PhpNuke..
If you are interested i will send you the code.
Henke
 
Posts: 3
Joined: Thu Jul 13, 2006 3:22 am
Location: São Paulo Brasil

Postby Vulcan » Fri Sep 22, 2006 11:37 am

Morning Henke,

For now i have modified the leonardo to work alone without phpbb or PhpNuke..
If you are interested i will send you the code.


woaooh ! Yes a lot ! of course all of us listen you :D

Vulcan
Vulcan
 
Posts: 4
Joined: Tue Jun 13, 2006 4:09 pm
Location: Digne les Bains

Does anyone know the rules about articles online?

Postby JamesMA » Mon Sep 26, 2011 2:57 am

I've just stubled upon this site as400-news.com, could I just copy the technical
articles from the site or do I need some kind of permission?. I am writing a project for school.

James
JamesMA
 
Posts: 1
Joined: Mon Sep 13, 2010 3:29 am
Location: United states


Return to Support

Who is online

Users browsing this forum: Yahoo [Bot] and 2 guests

cron
Bridge by mehdiplugins.com